The version of Samba running on the remote host is 4.13.x prior to 4.13.17, 4.14.x prior to 4.14.12, or 4.15.x prior to 4.15.5. It is, therefore, affected by multiple vulnerabilities:
- Out-of-bounds heap read/write vulnerability in VFS module vfs_fruit allows code execution. (CVE-2021-44142)
- Information leak via symlinks of existence of files or directories outside of the exported share. (CVE-2021-44141)
- Samba AD users with permission to write to an account can impersonate arbitrary services. (CVE-2022-0336)
Upgrade to Samba version 4.13.17, 4.14.12, or 4.15.5 or later.